EN DIRECT en ligne connexion / inscription
Connexion

Surnom/Pseudo
Mot de Passe :

[ Vous avez perdu votre mot de pass ? | Devenir membre ]

×

VA API : Vidéo Accélération

CowcotLand topic RSS feed Surveiller les réponses de ce sujet
Hubo @
Paysan
Paysan

507pts

Inscrit le: 30 mars 2019
Age: 54
Messages: 224
Localisation: Seine-Maritime
Navigateur : Firefox

Hors ligne
Message Posté le: 17 avril 2019 à 22:45  Lien permanent
Répondre en citant
Ça faisait un moment que je cherchais à résoudre un problème avec les vidéos YT pour lesquelles il m'était impossible de les visionner en 1080P, un comble avec une Sapphire VaporX ATI Radeon HD 4870, 1024 MBytes !
En suivant le Wiki pour résoudre mon problème avec la gestion énergie/performances, j'ai continué dans ma lançée et j'ai résolu un autre point important, maintenant, je peux visionner les vidéos en 1080P sur YT et avoir un meilleur rendu pour les films lus via VLC.

VA API : Vidéo Accélération
https://doc.ubuntu-fr.org/vaapi#pilote_libre_radeon

1.4 Pilote libre radeon (recommandé)
J'ai installé vainfo via le gestionnaire des paquets synaptic pour vérifier :


Donc avec la commande vainfo, j'avais ça :
Citation:
libva info: VA-API version 0.36.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/r600_drv_video.so
libva info: Found init function __vaDriverInit_0_35
Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object file: No such file or directory
libva error: /usr/lib/x86_64-linux-gnu/dri/r600_drv_video.so init failed
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit
VDPAU n'était pas installé, je l'ai trouvé (le bougre) en tapant vdpau dans la barre de recherche du gestionnaire des paquets synaptic :

Je tape à nouveau la commande vainfo et là c'était bon :
Citation:
libva info: VA-API version 0.36.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/r600_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.36 (libva 1.4.1)
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.4
vainfo: Supported profile and entrypoints
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointVLD
M'enfin...


Suite à des tests qui m'ont fait voir que la technologie Flash n'était pour rien dans la qualité des vidéos YT en HD, j'ai décidé de ne pas recourir à cette technologie obsolète et dangereuse ; j'ai simplement supprimé le répertoire Adobe situé dans etc ; la qualité des vidéos est due au point 1.4 et non à ce dernier point (1.5) j'ai été un peu vite sur le coup.


1.5 Activation des vidéos Flash
Pour améliorer la qualité des vidéos flash j'ai donc entré la commande :
Citation:
sudo mkdir /etc/adobe
sudo echo -e "EnableLinuxHWVideoDecode = 1\nOverrideGPUValidation = 1" | sudo tee /etc/adobe/mms.cfg
Maintenant, j'ai une nette amélioration au niveau de la qualité des vidéos flash (YT en HD c'est mieux)


etc/adobe/mms.config :



Voilà deux choses une chose qui me changent carrément aux niveau qualité des vidéos Clin d'oeil


Un poussin égal deux...

Dernière édition par Hubo le 18 avril 2019 à 15:13; édité 3 fois
Voir le profil de l'utilisateur Envoyer un message privé » Album Photos
garzebuth @
Fermier
Fermier

5710pts

Inscrit le: 30 novembre 2011
Messages: 3425

Navigateur : n.c.

Hors ligne
Message Posté le: 17 avril 2019 à 23:19  Lien permanent
Répondre en citant
Le mieux serait encore de ne pas avoir flash du tout et d'utiliser html5 quand même.
Voir le profil de l'utilisateur Envoyer un message privé
Hubo @
Paysan
Paysan

507pts

Inscrit le: 30 mars 2019
Age: 54
Messages: 224
Localisation: Seine-Maritime
Navigateur : Firefox

Hors ligne
Message Posté le: 18 avril 2019 à 09:42  Lien permanent
Répondre en citant
Message initial supprimé, car la technologie Flash est dépassée et sera de toute façon abandonnée en 2020 et interdite en 2021...
De plus j'ai remarqué une consommation plus élevée au niveau du CPU avec la technologie Flash, par rapport au Html5 et aucune amélioration au niveau de la qualité des vidéos..

Donc adieu Flash et vive le Html5 Très content


Un poussin égal deux...
Voir le profil de l'utilisateur Envoyer un message privé » Album Photos
Sauter vers: 
Surveiller les réponses de ce sujet CowcotLand topic RSS feed  

Vous ne pouvez pas poster de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas voter dans les sondages de ce forum


Sujets similaires

Sujet Auteur Forum Réponses Posté le
Pas de nouveau message probleme de difussion video tbw Présentation 1 28 novembre 2021 à 09:34
Pas de nouveau message Configuration : Gaming / Vidéo 4K leelof L'atelier 13 26 octobre 2021 à 14:16
Pas de nouveau message Nouveau PC montage vidéo et loisir pour les 10 ans à venir Kolkoz L'atelier 43 07 octobre 2021 à 10:40
Topic Verrouillé [VDS] PC core i5 16Go carte vidéo PRO SSD 250 blinkonly Ventes 7 18 août 2021 à 16:19
Pas de nouveau message Nouveau téléphone dans la vidéo de L'Odyssey G9 néo ? Esgalion Téléphones portables 1 20 juillet 2021 à 15:38