EN DIRECT 1512 connexion / inscription
Connexion

Surnom/Pseudo
Mot de Passe :

[ Vous avez perdu votre mot de pass ? | Devenir membre ]

×

[Résolu]Gestion énergie/performances CG ATI

CowcotLand topic RSS feed Surveiller les réponses de ce sujet
Hubo
Ouvrier agricole
Ouvrier agricole

423pts

Inscrit le: 30 mars 2019
Age: 52
Messages: 188
Localisation: Seine-Maritime
Navigateur : Firefox

Hors ligne
Message Posté le: Mercredi 17 Avr 2019 à 08:23:22  Lien permanent
Répondre en citant
Salut les fermiers !

Ça fait un petit moment que je suis sous Linux, j'ai essayé pas mal de distros et ça va faire à peu près cinq ans que j'ai trouvé celle qui me convient, elle s'appelle Point Linux et elle est basée sur Debian avec l'environnement de bureau Mate, la version installée est la 3.2 (jessie) le noyau Linux 3.16.0.8-amd64, la version de Mate est la 1.8.1. Pour ce qui est du matériel, c'est dans ma deuxième config. Ma carte graphique est une ATI Radeon 4870 1G0 Vapor-X. J'ai choisi cette distrib car elle est simple de fonctionnement (je commence à vieillir alors je veux du simple Sourire )

Ce que je sait :

J'ai bien le pilote libre Radeon d'après la commande : lspci -nn | grep VGA

VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV770 [Radeon HD 4870]
Citation:
wx@tour:~$ lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 10)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV770 [Radeon HD 4870]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV770 HDMI Audio [Radeon HD 4850/4870]
02:01.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)


La commande pour vérifier si j'utilise lightdm comme fenêtre de connexion : cat /etc/X11/default-display-manager

/usr/sbin/lightdm



Je voudrais activer le DPM (Dynamic power management) mais j'avoue que je sèche un peu (surtout peur de faire une cownerie)

Ce que me donne la commande : sudo cat /sys/kernel/debug/dri/64/radeon_pm_info

default engine clock: 750000 kHz
current engine clock: 750000 kHz
default memory clock: 900000 kHz
current memory clock: 900000 kHz
voltage: 1263 mV
PCIE lanes: 16


Le Wiki sur lequel j’essaye de m’appuyer :
https://doc.ubuntu-fr.org/radeon :


En fait, j'ai l'impression que ma CG monte trop en température, j'ai pas la main pour les réglages, la seule info que j'ai c'est la température qui oscille entre 76 et 78 C° aussi la température au repos me semble trop élevée elle devrait être 10C° en dessous normalement (bon elle a dix ans quand même titine)

Si vous avez des infos pour activer ce DPM ce serait cool.

@+

Édité :

J'avance doucettement (pas évident évident...) voilà où j'en suis :

J'ai suivi les infos :
Pour activer le DPM (Dynamic power management), il faut activer son support dans le noyau Linux. ->
https://askubuntu.com/questions/442817/how-to-activate-radeon-dynamic-power-management
Citation:
You can check if DPM is working from the terminal by running: sudo cat /sys/kernel/debug/dri/64/radeon_pm_info. Source: askubuntu.com/questions/324733/… . Also the info about DPM might be in a different directory. Read the link for more details.
donc le DPM n'est pas activé c'est sûr.

Citation:
Using the dynamic power management feature requires updated firmware for the graphics card. The latest Radeon microcode/firmware can be downloaded from this directory. You need the *_smc.bin files from June. If you're unsure of your specific graphics card codename, you can generally find it from looking at output of lspci -v | less ... The file(s) need to be placed within /lib/firmware/radeon. If you try to use Radeon DPM without the firmware, acceleration will end up being disabled for the GPU. You also need to make sure you have the updated firmware in /lib/firmware/radeon before installing the >3.11 kernel - it will be pulled automagically into the installed image.
En suivant le chemin indiqué pour Ubuntu, j'ai bien trouvé ce fichier smc.bin
https://askubuntu.com/questions/324733/how-to-enable-the-radeon-dynamic-power-management-feature/326858#326858


Par contre là, je bloque un peu pour le moment :
https://wiki.ubuntu.com/Kernel/KernelBootParameters
https://www.kernel.org/doc/html/latest/admin-guide/kernel-parameters.html

Édité :

Là, apparemment je rempli les conditions (paquets installés...), mais je ne vois toujours pas comment activer ce p*tain de DPM...

https://wiki.debian.org/fr/AtiHowTo
https://manpages.debian.org/jessie/xserver-xorg-core/xorg.conf.5.en.html
https://www.x.org/wiki/radeonhd:INSTALL/

Pour ce qui du firmware flgrx, les cartes ne sont supportées qu'à partir de la HD5000 (c'est ballot à 30 près Maléfique )

Citation:
The Radeon DPM support is not enabled by default below Linux kernel 3.13, or for older GPUs. You must add the radeon.dpm=1 parameter to the Linux kernel to enable it in these cases.
Il faudrait que je teste ça.

Temporarily Add a Kernel Boot Parameter for Testing
https://wiki.ubuntu.com/Kernel/KernelBootParameters


Un poussin égal deux...

Dernière édition par Hubo le Mercredi 17 Avr 2019 à 20:56:04; édité 1 fois
Voir le profil de l'utilisateur Envoyer un message privé » Album Photos
Hubo
Ouvrier agricole
Ouvrier agricole

423pts

Inscrit le: 30 mars 2019
Age: 52
Messages: 188
Localisation: Seine-Maritime
Navigateur : Firefox

Hors ligne
Message Posté le: Mercredi 17 Avr 2019 à 20:55:31  Lien permanent
Répondre en citant
Ah je crois que j'ai enfin réussi à régler mon problème, la température est descendue de 10C° Moqueur

J'ai suivi ce lien :
https://doc.ubuntu-fr.org/radeon
Citation:

4.1 Gestion dynamique matérielle
Attention, on modifie ici des options de démarrage, une manipulation non compatible risque d'empêcher votre machine de démarrer.

Vous pouvez faire cela en ajoutant la commande "radeon.dpm=1" au fichier de configuration /etc/default/grub:

Ouvrez le fichier /etc/default/grub avec des droits d'administration.

Repérez la ligne

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Modifiez la en:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=1"

Puis enregistrez.

Il reste alors à mettre Grub à jour:

sudo update-grub

L'effet sera actif au prochain démarrage.

Au cas où votre OS ne démarre plus, il est conseillé de tester auparavant avec :

GRUB_CMDLINE_LINUX_DEFAULT="radeon.dpm=1"


Maintenant quand je tape la commande :
sudo cat /sys/kernel/debug/dri/64/radeon_pm_info

J'ai ça :
uvd vclk: 0 dclk: 0
power level 0 sclk: 50000 mclk: 90000 vddc: 1263


Ça change de ça :
default engine clock: 750000 kHz
current engine clock: 750000 kHz
default memory clock: 900000 kHz
current memory clock: 900000 kHz
voltage: 1263 mV
PCIE lanes: 16


Non mais...

Avant/Après :


Euréka Ch0cola


Un poussin égal deux...

Dernière édition par Hubo le Jeudi 18 Avr 2019 à 10:27:30; édité 1 fois
Voir le profil de l'utilisateur Envoyer un message privé » Album Photos
ggcom
Saisonnier
Saisonnier

241pts

Inscrit le: 04 novembre 2018
Messages: 150

Navigateur : n.c.

Hors ligne
Message Posté le: Jeudi 18 Avr 2019 à 00:10:15  Lien permanent
Répondre en citant
Ton post m'a intéressé mais je n'ai pas le fichier :
/sys/kernel/debug/dri/64/radeon_pm_info
mais par contre j'ai l'impression que le DPM est activé quand même.
Je suis sous Ubuntu avec une RX 560
Je vais suivre
https://askubuntu.com/questions/442817/how-to-activate-radeon-dynamic-power-management
edit : c'est un échec...
Finalement le fichier radeon_pm_info à migrer : /sys/kernel/debug/dri/0/amdgpu_pm_info
Il ne me manque plus qu'à le comprendre.
Charge 26 % Temp 40°C
Cela doit fonctionner car la carte consomme moins de 10W.
Voir le profil de l'utilisateur Envoyer un message privé
Hubo
Ouvrier agricole
Ouvrier agricole

423pts

Inscrit le: 30 mars 2019
Age: 52
Messages: 188
Localisation: Seine-Maritime
Navigateur : Firefox

Hors ligne
Message Posté le: Jeudi 18 Avr 2019 à 15:54:26  Lien permanent
Répondre en citant
Salut,

Que te donne la commande ? :
Code:
dmesg | grep radeon


Si c'est activé, tu devrais voir une ligne avec :
[drm] radeon: dpm initialized

Édité :

Je viens de voir les specs de ta CG et vu l'année de sortie (2017) vu la "compatibilité" avec Linux (Ubuntu x86 64-Bit, Linux x86_64) vu la consommation en watt (60-80 W) et les 10W que tu as relevé, tu es tranquille ; moi c'est beaucoup moins évident, c'est une carte plus vieille (2009) même pas le choix du pilote proprio, si je ne m'était pas aperçu que le DPM n'était pas activé, ça aurai consommé plus que la normale (toujours au max) et ça chauffe le PC donc tout les composants en pâtissent, je doit augmenter la vitesse des ventilos donc plus de bruit, l'usure (cette fois oui Très content ) etc.

Je vais faire un petit résumé en reprenant mon premier post, je vais mettre ça au clair, si ça peut en aider d'autres...

@+


Un poussin égal deux...
Voir le profil de l'utilisateur Envoyer un message privé » Album Photos
Sauter vers: 
Surveiller les réponses de ce sujet CowcotLand topic RSS feed  

Vous ne pouvez pas poster de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas voter dans les sondages de ce forum


Sujets similaires

Sujet Auteur Forum Réponses Posté le
Pas de nouveau message [RESOLU] Débit faible NAS Synology D218Play THEseb Questions diverses... 46 Mardi 14 Mai 2019 à 08:18:20
Pas de nouveau message [RESOLU] PANNE MX500 M.2 GinKamui SSD 18 Vendredi 10 Mai 2019 à 15:07:35
Pas de nouveau message [RESOLU] Votre avis sur une annonce d'occasion SVP herve31 Questions diverses... 3 Vendredi 10 Mai 2019 à 13:13:16
Topic Verrouillé [Résolu]Problème d'image noir pendanrt les jeux ggcom Optimisation Windows 12 Jeudi 9 Mai 2019 à 22:30:54
Pas de nouveau message [Résolu] écran noir pendant le jeu ggcom Cartes Graphiques 26 Mercredi 8 Mai 2019 à 18:13:08