EN DIRECT 2009 connexion / inscription
Connexion

Surnom/Pseudo
Mot de Passe :

[ Vous avez perdu votre mot de pass ? | Devenir membre ]

×

[Résolu] Problème de boot archlinux + gtx 970 KMS et EFI

CowcotLand topic RSS feed Surveiller les réponses de ce sujet
garzebuth
Fermier
Fermier

5298pts

Inscrit le: 30 novembre 2011
Messages: 3250

Navigateur : n.c.

Hors ligne
Message Posté le: Jeudi 16 Oct 2014 à 00:02:20  Lien permanent
Répondre en citant
OK les gars, je vous raconte mon histoire.

J'ai fait l'acquisition d'une gtx 970 il y a quelques jours, j'en suis par ailleurs très heureux.

Seulement, au redémarrage de mon PC (dual boot windows/archlinux) voilà que le boot freeze quand je veux lancer arch. En gros tout se passe bien jusqu'à ce qu' udev vienne stopper tout ça.
Là je me suis frappé le front parce que comme un con j'avais pas fait de maj avant, à tous les coups c'est un module du noyau ou nouveau qui doit être mis à jour.
Donc je m'arme de la dernière iso pour booter dessus et réparer ma connerie. Sauf que là mauvaise surprise, ça s'arrête au millieu du boot aussi. Donc j'essaie avec une clef live linux mint qui trainait par là, et là miracle je boote.

Donc après un tour dans mon install via chroot, j'ai:
-mis à jour le système
-recompilé mon image linux (parce qu'en effet il y avait bien eu une maj du noyau)

Au reboot, pas mieux. Donc rebelotte, cette fois j'ai :
-réinstallé systemd que j'avais supprimé
-remis systemd comme processus d'init
-réinstallé nouveau

Et toujours pas de changement. Le fichier log d'openrc me dit rien de spécial, il s'arrête juste de loguer à un moment.


Quelqu'un a-t-il eu une expérience similaire ? Une idée qui pourrait m'avancer ? Un lien (j'ai pas trouvé mais sait-on jamais) ?


Dernière édition par garzebuth le Vendredi 21 Nov 2014 à 17:36:37; édité 1 fois
Voir le profil de l'utilisateur Envoyer un message privé
garzebuth
Fermier
Fermier

5298pts

Inscrit le: 30 novembre 2011
Messages: 3250

Navigateur : n.c.

Hors ligne
Message Posté le: Vendredi 21 Nov 2014 à 17:34:21  Lien permanent
Répondre en citant
Je m'auto up puisque après avoir laissé trainer un bout de temps j'ai décidé de m'attaquer au problème, j'en reviens donc avec une ou deux infos qui vont peut-être intéresser les plus linuxiens d'entre vous.

Le soucis se situe au niveau du KMS; apparemment en mode de boot efi la 970 n'est pas capable de l'utiliser ce qui forcément frezze l'affichage au moment où celui-ci bascule.
Un simple nomodeset dans les paramètres du noyau permet donc de contourner le problème (oui c'est simple, mais pour ma défense j'y aurais pensé avant si il n'y avait pas eu cette bizarrerie entre le boot en mode bios et le boot en mode efi Moqueur ).

Ca devrait changer dans le futur, NVIDIA ayant fait pas mal d'annonces au sujet du refactoring de ses pilotes linux pour mieux respecter l'écosystème en place et notamment implémenter le support du KMS (ainsi que wayland !). Plus d'infos ici:
http://www.phoronix.com/scan.php?page=news_item&px=MTgxMDE

Bref une fois après avoir réussi à booter jusqu'à une TTY le soucis suivant a été de démarrer X: pour ça il faut un driver graphique évidemment, et jusqu'à présent j'utilisais nouveau (car le driver proprio pose quelques soucis surtout dans la console), sauf que nouveau a besoin de KMS pour fonctionner. Donc pas le choix, obligé de repasser sur les driver proprio, je verrai ce que ça donne.


Donc pour résumer le fonctionnement d'une 970 sous linux :
en boot legacy: aucun soucis à priori
en boot efi : il faut désactiver le KMS et on est donc obligé de switcher sur les driver proprio.


Comme toujours avec linux quand on a commencé on ne s'arrête plus, et je ne me suis donc piqué de tester le boot via un efistub, donc en se débarrassant de grub, qui met 2 plombes à démarrer et est une petite crotte à configurer.

Pour ça rien de plus simple, comme souvent avec linux une ligne de commande suffit (ou presque). Il faut donc :

1 - monter la partition EFI dans /boot . C'est pas obligatoire et si vous avez déjà une install celle-ci est surement montée sur /boot/efi mais ça permet à pacman de mettre à jour le noyau automatiquement, sinon il trouve pas les images et c'est à faire à la main. Et puis en plus le reste de /boot ne sert plus à rien et on évite aussi de monter une partition pour que dalle au démarrage. Edit: et ne pas oublier de mettre les différentes images linux sur la partition, de préférence sur un chemin logique (genre /EFI/arch/<images>).
2 - utiliser la commande efibootmgr pour ajouter/lister/modifier/supprimer les entrées visibles dans le bios l'efi. La commande est plutôt simple, il faut mettre les chemins vers les différentes images, un label et les options du noyau et hop c'est fini.

Plus d'infos ici: https://wiki.archlinux.org/index.php/EFISTUB#Using_UEFI_directly_.28efibootmgr.29

Résultat c'est plutôt plus simple que grub à configurer, ça marche nickel et, pour ceux qui aiment ça, ça enlève 1-2 secondes au boot. La condition par contre c'est que les options de démarrage soient faciles d'accès au niveau de l'efi, chez moi une simple pression sur F12 suffit donc aucun soucis.
Voir le profil de l'utilisateur Envoyer un message privé
Sauter vers: 
Surveiller les réponses de ce sujet CowcotLand topic RSS feed  

Vous ne pouvez pas poster de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas voter dans les sondages de ce forum


Sujets similaires

Sujet Auteur Forum Réponses Posté le
Pas de nouveau message Pourquoi mon DVD Drive n'est pas vu lors du boot ? sukkoi3 Optimisation Windows 10 Mercredi 19 Fév 2020 à 16:21:09
Pas de nouveau message [RESOLU] Problème nvme m.2 non reconnu otra SSD 8 Jeudi 13 Fév 2020 à 23:38:57
Pas de nouveau message X570 AORUS ULTRA: Boot ou PAS avec Profil XMP Osbastien CPU, Cartes mères, RAM 37 Jeudi 13 Fév 2020 à 02:17:03
Pas de nouveau message Problème sur ma configuration PC Zenithy L'atelier 2 Lundi 10 Fév 2020 à 13:52:50
Pas de nouveau message Problème température Cpu dans Level 20 XT de thermaltake dok57 Boitiers/racks 12 Lundi 10 Fév 2020 à 08:17:17