EN DIRECT en ligne connexion / inscription
Connexion

Surnom/Pseudo
Mot de Passe :

[ Vous avez perdu votre mot de pass ? | Devenir membre ]

×

AMD RAID

CowcotLand topic RSS feed Surveiller les réponses de ce sujet
bidule2000 @
Saisonnier
Saisonnier

132pts

Inscrit le: 25 juillet 2020
Messages: 27

Navigateur : n.c.

Hors ligne
Message Posté le: 29 janvier 2021 à 14:37  Lien permanent
Répondre en citant
Bonjour,
Je viens de monter une nouvelle config qui comprend:
- MSI B550 Gaming Plus
- AMD Ryzen 7 3700X
- SSD 850 EVO M.2 SATA x 1
- HDD WD 2To x 2

Je veux installer l'OS sur le SSD et faire un RAID 1 avec les 2 HDD.
Dans le BIOS, j'ai activé le mode RAID.
J'ai l'impression que je suis obligé de créer une array ne contenant que mon SSD (en mode RAIDABLE) sinon je n'arrive pas à voir mon SSD pour installer Windows.
Du coup ça m'ennuie un peu car lorsque je fait de cette manière, sous Windows, je n'ai pas accès aux informations matérielles de mon SSD (Température...).
Sur mon ancienne config (à base de Core i7 6700 et H170) je ne devais créer qu'un seul volume RAID pour mes 2 HDD.
Mon SSD était bien vu par Windows comme un SSD et pas un volume RAID.
De plus, je trouve que la configuration du RAID était bien plus explicite sur mon ancienne config Intel (et en plus pas besoin de rajouter de pilotes pour installer Windows !) mais bon ça c'est encore autre chose.
Je ne sais pas si d'autres ont le même type de configuration et ont été obligé de monter un volume RAID pour leur SSD.
Merci.
Voir le profil de l'utilisateur Envoyer un message privé
fission @
Meuhdérateur
Meuhdérateur

2703pts

Inscrit le: 08 mars 2019
Messages: 2276
Localisation: ile de france
Navigateur : n.c.

En ligne
Message Posté le: 29 janvier 2021 à 14:52  Lien permanent
Répondre en citant
alors voilà comment je procéderais :


-débrancher les 2 hdds et ne pas activer le raid
-installation de windows sur le ssd
-débrancher le ssd et brancher les 2 hdds
-activation du mode raid
-création du raid avec les 2 hdds
-brancher le ssd
-démarrer windows en mode sans échec
-démarrer windows en mode normal

Perso j'ai une aorus Z390 master g2 avec 3 ssd + raid entre 2 hdds et ca ne pose aucun problème.


Voir le profil de l'utilisateur Envoyer un message privé
bidule2000 @
Saisonnier
Saisonnier

132pts

Inscrit le: 25 juillet 2020
Messages: 27

Navigateur : n.c.

Hors ligne
Message Posté le: 29 janvier 2021 à 15:00  Lien permanent
Répondre en citant
Je suis désolé mais j'ai bien peur qu'une fois que je serai passé du mode AHCI au mode RAID je perdrais mon OS et je ne pourrai plus booter dessus.
Sur mon ancienne config sous Intel je n'avais pas eu ce type de problème et directement en mode RAID mon SSD était bien vu pour ce qu'il était et pas pour un volume RAID.
Voir le profil de l'utilisateur Envoyer un message privé
fission @
Meuhdérateur
Meuhdérateur

2703pts

Inscrit le: 08 mars 2019
Messages: 2276
Localisation: ile de france
Navigateur : n.c.

En ligne
Message Posté le: 29 janvier 2021 à 15:17  Lien permanent
Répondre en citant
en passant du ahci au raid tu perdra pas ton OS, il faudra juste passer une fois par le mode sans échec ( y'aura rien a modifier ) . Je l'ai fait sur ma machine et ca a très bien fonctionné et fonctionne toujours ! une fois de retour dans le windows en mode normal, tu installera le pilote pour que le raid soir reconnu c'est tout !


Voir le profil de l'utilisateur Envoyer un message privé
bidule2000 @
Saisonnier
Saisonnier

132pts

Inscrit le: 25 juillet 2020
Messages: 27

Navigateur : n.c.

Hors ligne
Message Posté le: 29 janvier 2021 à 15:30  Lien permanent
Répondre en citant
Tu as l'air bien sur de toi.
Je vais donc essayer de tester ça ce week-end mais je t'avoue que je vais d'abord faire quelques sauvegardes car je ne suis pas très serein sur ce coup là !
Voir le profil de l'utilisateur Envoyer un message privé
fission @
Meuhdérateur
Meuhdérateur

2703pts

Inscrit le: 08 mars 2019
Messages: 2276
Localisation: ile de france
Navigateur : n.c.

En ligne
Message Posté le: 29 janvier 2021 à 16:26  Lien permanent
Répondre en citant
je suis sur de moi:


-tu ne perd aucune donnée sur le ssd en passant du ahci au raid ( sauf si ton ssd faisait partie d'un raid au préalable )

-les données sur tes hdds seront perdus quand tu fabriquera le raid via le bios même si les disques faisaient partie d'un raid avant !


Voir le profil de l'utilisateur Envoyer un message privé
bidule2000 @
Saisonnier
Saisonnier

132pts

Inscrit le: 25 juillet 2020
Messages: 27

Navigateur : n.c.

Hors ligne
Message Posté le: 30 janvier 2021 à 17:13  Lien permanent
Répondre en citant
Voici donc ce que j'ai fait hier soir:
- Passer en mode AHCI
- Installer Windows en mode AHCI
- Après installation passer en mode RAID
- Tentative de boot -> Inaccessible boot device
- Lancement du mode sans échec -> Inaccessible boot device

Du coup j'ai réinstallé Windows avec mon SSD en mode RAID (cette fois je n'ai pas été obligé de créer une array pour le SSD. Le disque était vu en non-raid dans le BIOS).
Sous Windows mon SSD est vu comme "AMD Raid Samsung SSD 850 SCSI Disk Device".
Sous HSWMonitor, je ne vois pas mes disque physiques, je ne vois que "AMD Raid Samsung SSD 850 SCSI Disk Device" et "AMD Raid Array 1 SCSI Disk Device".
Pourtant avec mon ancienne config en mode RAID, sous HSWMonitor, je voyais bien mes 3 disque physiques avec leurs températures.
Je pense que le RAID de mon ancienne config était supporté nativement par Windows 10 (pas de pilote à rajouter lors de l'installation) ce qui n'est plus le cas de ma nouvelle config.
Je vais donc arrêter mes tests là et je vais devoir apprendre à me passer du monitoring de mes disques physiques Pleure ou Très triste
Tant pis.
Voir le profil de l'utilisateur Envoyer un message privé
fission @
Meuhdérateur
Meuhdérateur

2703pts

Inscrit le: 08 mars 2019
Messages: 2276
Localisation: ile de france
Navigateur : n.c.

En ligne
Message Posté le: 30 janvier 2021 à 17:30  Lien permanent
Répondre en citant
bidule2000 a écrit:
- Après installation passer en mode RAID
- Tentative de boot -> Inaccessible boot device
- Lancement du mode sans échec -> Inaccessible boot device


Inaccessible boot device ..... tu as du oublié de changer un truc dans le boot order !


Voir le profil de l'utilisateur Envoyer un message privé
bidule2000 @
Saisonnier
Saisonnier

132pts

Inscrit le: 25 juillet 2020
Messages: 27

Navigateur : n.c.

Hors ligne
Message Posté le: 31 janvier 2021 à 08:36  Lien permanent
Répondre en citant
Pour info, je n'ai rien changé dans le boot order et le fait de passer du mode AHCi au mode RAID, pour moi c'est totalement logique que mon installation de Windows ne soit plus vu.
Quoiqu'il en soit, il semble que mon logiciel de monitoring (HSWMONITOR) ne sache pas remonter toutes les informations de l'AMD RAID.
Pour l'instant je n'ai trouvé que HD Sentinel qui remontait et voyait correctement les températures de mes disques physiques.
Voir le profil de l'utilisateur Envoyer un message privé
Dysnome @
Métayer
Métayer

2890pts

Inscrit le: 29 août 2014
Messages: 623
Localisation: Luxembourg
Navigateur : n.c.

Hors ligne
Message Posté le: 31 janvier 2021 à 10:51  Lien permanent
Répondre en citant
Hello,

Je débarque peut-être après la guerre, voici mon feedback:

Si le S-ATA III est configuré en mode RAID, tu ne verras rien dans HWMonitor. Il n'y a tout simplement aucune "manipulation" possible, c'est le design qui est ainsi fait.
Si tu veux avoir ton SSD dans HWMonitor, il aurait fallu qu'il soit en PCIe (NVMe).

Dans mon cas j'ai deux grappes RAID (un RAID 0 et un RAID 1) de SSD en S-ATA III, et un SSD NVMe (970 EVO). Le seul que je vois dans HWMonitor c'est forcément le 970 EVO.

Donc soit t'es en mode RAID, soit t'as les infos dans HWMonitor, malheureusement les deux ne sont pas possible (hormis si tu investis dans une carte RAID dédiée).
Voir le profil de l'utilisateur Envoyer un message privé
fission @
Meuhdérateur
Meuhdérateur

2703pts

Inscrit le: 08 mars 2019
Messages: 2276
Localisation: ile de france
Navigateur : n.c.

En ligne
Message Posté le: 31 janvier 2021 à 12:50  Lien permanent
Répondre en citant
perso je vois les infos de temp de mes 2 hdds satas montés en raid dans crystaldisk 8.1

Pour ce qui est du boot order si je te dis que tu avais un truc a modifier c'est ce que j'ai basculer de ahci a raid sans réinstaller et que ce fonctionne très bien chez moi !


Voir le profil de l'utilisateur Envoyer un message privé
bidule2000 @
Saisonnier
Saisonnier

132pts

Inscrit le: 25 juillet 2020
Messages: 27

Navigateur : n.c.

Hors ligne
Message Posté le: 31 janvier 2021 à 14:49  Lien permanent
Répondre en citant
Je pense que c'est une limitation due aux pilotes de l'AMD RAID.
Sur mon ancienne config à base d'INTEL (H170) sous HSWMonitor je voyais très bien mes 3 disques physiques (Temp, activité...).
Désormais dans HSWMonitor je ne vois plus que mes 2 disque logiques ("AMD Raid Samsung SSD 850 SCSI Disk Device" et "AMD Raid Array 1 SCSI Disk Device").
Je vais donc attendre une hypothétique évolution de HSWMonitor ou bien une meilleure compatibilité avec le monitoring de l'AMD RAID.
Dans tous les cas merci à vous deux pour vos réponses.
Voir le profil de l'utilisateur Envoyer un message privé
chlorophyle @
Saisonnier
Saisonnier

225pts

Inscrit le: 17 juin 2015
Age: 45
Messages: 101
Localisation: assis sur un caisson de basse
Navigateur : Firefox

Hors ligne
Message Posté le: 31 janvier 2021 à 22:07  Lien permanent
Répondre en citant
Quelle idée saugrenue de vouloir utilisé le raid foireux de la carte mère, Windows est tout a fait capable de gérer un raid software potable.

Maintenant si tu veux absolument du raid matériel il te faut un contrôleur adéquat qui te permettra pour les mieux fourni de gérer et monitorer les disques.
Voir le profil de l'utilisateur Envoyer un message privé
bidule2000 @
Saisonnier
Saisonnier

132pts

Inscrit le: 25 juillet 2020
Messages: 27

Navigateur : n.c.

Hors ligne
Message Posté le: 01 février 2021 à 13:30  Lien permanent
Répondre en citant
Je me doute bien qu'un contrôleur dédié serait certainement plus approprié mais pour une utilisation strictement privé ça me va très bien.
Je n'ai pas besoin spécialement de grosses performances c'est juste pour sécuriser mes données.
Après c'est vrai que je n'ai pas pensé à faire un RAID logiciel via Windows.
En terme de performance entre les deux j'aurais tendance à dire que le RAID de ma CM serait peut-être meilleur qu'un RAID logiciel mais sans conviction.
De toute façon je n'ai pas l'intention de faire une course de RAID Clin d'oeil
Voir le profil de l'utilisateur Envoyer un message privé
Dysnome @
Métayer
Métayer

2890pts

Inscrit le: 29 août 2014
Messages: 623
Localisation: Luxembourg
Navigateur : n.c.

Hors ligne
Message Posté le: 01 février 2021 à 15:00  Lien permanent
Répondre en citant
chlorophyle a écrit:
Quelle idée saugrenue de vouloir utilisé le raid foireux de la carte mère, Windows est tout a fait capable de gérer un raid software potable.

Maintenant si tu veux absolument du raid matériel il te faut un contrôleur adéquat qui te permettra pour les mieux fourni de gérer et monitorer les disques.

C'est si répandu que ça de ton côté ? Dans les boîtes où j'ai été, dans mon entourage et de manière générale dans ce que je lis sur internet, très peu de gens utilisent le RAID software sous Windows (hors partie serveur).

Par contre sous Linux c'est fréquent de faire du software RAID (c'est même très simple)
Voir le profil de l'utilisateur Envoyer un message privé
Sauter vers: 
Surveiller les réponses de ce sujet CowcotLand topic RSS feed  

Vous ne pouvez pas poster de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas voter dans les sondages de ce forum


Sujets similaires

Sujet Auteur Forum Réponses Posté le
Pas de nouveau message Comment transférer un RAID 1 quand on change de carte mère ? vinvin Questions diverses... 5 17 décembre 2021 à 16:14
Pas de nouveau message Faire un "vrai" Raid 0" sur X570 avec 2 nvme SSD 500go Roro747 CPU, Cartes mères, RAM 2 06 mai 2021 à 22:55
Pas de nouveau message [Trouvé] RAID 0 sur Rampage extreme. Martin_White SSD 13 29 janvier 2019 à 21:06
Pas de nouveau message RAID incompréhensif loukass SSD 7 20 janvier 2019 à 20:12
Pas de nouveau message [RESOLU] SDD AHCI + RAID HDD? syndrome Optimisation Windows 4 09 août 2018 à 13:38